В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Aldiyar0708
Aldiyar0708
15.09.2022 09:35 •  Информатика

Написать программу: "дано четырехзначное число.что больше: сумма цифр,стоящих на четных местах,или сумма цифр,стоящих на не четных местах? "

Показать ответ
Ответ:
leo1010101
leo1010101
01.10.2020 17:13
Var a,s1,s2:integer;
begin
read (a);
if (a>=1000)and (a<=9999)then
begin
s1:=(a mod 10) + ((a mod 1000) div 100);
s2:=(a div 1000) + ((a mod 100) div 10);
if (s1>s2)then writeln ('Сумма цифр,стоящих на четных местах больше суммы цифр, стоящих на нечетных местах');
if (s1<s2)then writeln ('Сумма цифр,стоящих на нечетных местах больше суммы цифр, стоящих на четных местах');
if (s1=s2)then writeln ('Сумма цифр,стоящих на четных местах равна сумме цифр, стоящих на нечетных местах');
end
else writeln ('Вы ввели не 4-ёхзначное число');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота