В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
pomogiplizplizpliz
pomogiplizplizpliz
11.05.2023 00:17 •  Информатика

Написать программу.Дано два числа. Если хотя бы одно из них больше 30, то вывести yes, иначе no.Ввод числа пользователем ГОТОВЫЙ ОТВЕТ!​

Показать ответ
Ответ:
nkarlikova
nkarlikova
02.01.2021 19:03
Последовательность действий ученика при самостоятельном изучении параграфа учебника:
1) достать учебник
2) сесть за стол
3) открыть учебник
4) прочитать параграф
5) ответить на вопросы после параграфа
6) открыть тетрадь
7) сделать краткий конспект по вопросам в конце параграфа
8) закрыть тетрадь
9) закрыть учебник
10) убрать учебник

Последовательность действий мамы при варке манной каши:
1) взять кастрюлю
2) налить воду в кастрюлю
3) зажечь огонь на плите
4) поставить кастрюлю на огонь
5) достать крупу, молоко
6) добавить в кастрюлю молоко
7) когда вода и молоко закипят добавить крупу
8) взять ложку
9) мешать ложкой крупу
10) накрыть крышкой
11) выключить огонь под кастрюлей
0,0(0 оценок)
Ответ:
Мухамед5Ли
Мухамед5Ли
07.08.2020 01:19

#include <iostream>

#include <vector>

using namespace std;

int am_dig(int k){

   int res = 0;

   while(k > 0){

       res++;

       k /= 10;

   }

   return res;

}

double average(vector<double> a){

   double sum = 0;

   for(auto i: a)

       sum += i;

   return sum/a.size();

}

int main() {

   vector<double> a;

   double x = 1;

   while(x != 0){

       cin >> x;

       if(am_dig(x) == 3)

           a.push_back(x);

   }

   if(a.size() == 0)

       cout << "NO";

   else

       cout << average(a);

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота