В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
avetik04
avetik04
13.07.2022 02:47 •  Информатика

Написать программу. даны точки а(х1,у1) и в(х2,у2). определить, какая из точек располагается ближе к центру координат.

Показать ответ
Ответ:
максимус67
максимус67
08.10.2020 02:09
Program HelloWorld;var x1,y1,x2,y2:double;begin    readln(x1);    readln(y1);    readln(x2);    readln(y2);    x1:=sqrt(x1*x1+y1*y1);    x2:=sqrt(x2*x2+y2*y2);    if(x1>x2) then writeln(x2:0:2)    else if(x2>x1) then writeln(x1:0:2)    else writeln('Одинаково близко',x1:0:2);end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота