В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Написать программу для чертежника. может кто то делал и знает как, подскажите как ​

Показать ответ
Ответ:
prunsesca005
prunsesca005
10.05.2020 08:43
Const
  problems : array [0..9] of String = ('x1+5=10', 'x1+5=10', 'x1+5=10', 'x1+5=10', 'x1+5=10', 'x1+5=10', 'x1+5=10','x1+5=10', 'x1+5=10', 'x1+5=10');
  answers : array [0..9] of String = ('-5', '-5', '-5', '-5', '-5', '-5', '-5', '-5', '-5', '-5');
var
  countOfAnswers, counter: integer;
  userAnswer: String;
begin
  countOfAnswers := 0;
  for counter:=0 to 9 do
    begin
      write('Введите ответ уравнения ', problems[counter], ' : ');
      readln(userAnswer);
      if userAnswer = answers[counter] then Inc(countOfAnswers);
    end;
if countOfAnswers > 8 then writeln('Отлично')
    else if countOfAnswers > 5 then writeln('Хорошо')
    else writeln('Плохо');
end.
0,0(0 оценок)
Ответ:
Снежана341
Снежана341
18.12.2021 16:30
// PascalABC.NET 3.0, сборка 1073
const
  nn=30;
  mm=30;
var
  a:array[1..mm,1..nn] of integer;
  m,n,i,j,imax,imin,jmax,jmin:integer;
begin
  Writeln('Введите число строк и столбцов массива: '); Read(m,n);
  Randomize;
  Writeln('*** Исходный массив ***');
  imin:=1; jmin:=1; imax:=1; jmax:=1;
  for i:=1 to m do begin
    for j:=1 to n do begin
      a[i,j]:=Random(51)-25;
      Write(a[i,j]:4);
      if a[i,j] mod 2 = 0 then begin
        if a[i,j]<a[imin,jmin] then
          begin imin:=i; jmin:=j end
        else
          if a[i,j]>a[imax,jmax] then
            begin imax:=i; jmax:=j end
      end
    end;
    Writeln
  end;
  Writeln('*** Результирующий массив ***');
  for i:=1 to m do begin
    for j:=1 to n do begin
      if (i=imin) and (j=jmin) or (i=imax) and (j=jmax) then a[i,j]:=2*a[i,j]
      else a[i,j]:=3*a[i,j];
      Write(a[i,j]:4)
    end;
    Writeln
  end
end.

Тестовое решение:
Введите число строк и столбцов массива:
10 8
*** Исходный массив ***
 -18   9  23 -18  -3  12   4 -22
  16 -24   7  -1  11   5  21 -25
  20 -11  14 -13  13 -21  13  -2
 -20   2  10 -19  -4   5  -7 -21
  16  17 -11   1   2 -18  21   0
  -2 -10  -6   3  25  16   5  -9
 -12   9   7 -21  22  -1 -25 -23
  22   0 -24  21 -23  -3   7 -15
   8   3   8  20 -10  -5  -2  13
  -6 -12  15  -3  11 -16  -1 -10
*** Результирующий массив ***
 -54  27  69 -54  -9  36  12 -66
  48 -48  21  -3  33  15  63 -75
  60 -33  42 -39  39 -63  39  -6
 -60   6  30 -57 -12  15 -21 -63
  48  51 -33   3   6 -54  63   0
  -6 -30 -18   9  75  48  15 -27
 -36  27  21 -63  44  -3 -75 -69
  66   0 -72  63 -69  -9  21 -45
  24   9  24  60 -30 -15  -6  39
 -18 -36  45  -9  33 -48  -3 -30
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота