В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Mrskiss
Mrskiss
08.05.2021 20:56 •  Информатика

Написать программу для кумира «сумма первых натуральных чисел» напишите письменно, ❤️

Показать ответ
Ответ:
TToMoLLIHuK1
TToMoLLIHuK1
06.02.2020 09:21

Объяснение:

// Example program

#include <iostream>

#include <string>

int main()

{

   int k[30];

   for(int i = 0; i < 30; i ++) //заполняем случайными числами

       k[i] = rand();

   int min_sum = 999999999;

   int num1, num2;

   for(int i = 0; i < (30 - 1); i ++) //цикл поиска, i меняется от начала

                                      //до предпоследнего элемента, чтобы не выйти

                                      //за пределы при обращении к i + 1 элементу

   {

       int sum = k[i] + k[i+1];//очередная сумма

       if(sum < min_sum) //сравниваем ее с текущим минимумом

       {//если она меньше, то

           min_sum = sum;//обновляем текущую сумму

           num1 = i; num2 = i + 1;//обновляем номер

       }

   }

   //на выходе из цикла в min_sum и num1 и num2 имеем самые минимальные номера

   std::cout << "min_sum = " << min_sum << " nomer1 = " << num1 <<" nomer2 = " << num2;

}


решить задачу на C++ Дан целочисленный массив из 30 элементов. Элементы массива могут принимать прои
решить задачу на C++ Дан целочисленный массив из 30 элементов. Элементы массива могут принимать прои
0,0(0 оценок)
Ответ:
KarinaFelton
KarinaFelton
24.03.2020 14:11

Архитектурой компьютера называют описание основных устройств компьютера и принципов их работы.

Любой персональный компьютер включает в себя четыре блока:

1. Системный блок – в нем располагаются основные компоненты компьютера, к нему подключаются различные внешние устройства.

2. Монитор – на нем отражается полученная информация в процессе работы текстового или графического редактора.

3. Клавиатура – предназначена для ввода в компьютер текстовой информации и различных команд.

4. Мышь – манипулятор, предназначенный для указания различных объектов на экране монитора и выбора команд, облегчая работу на компьютере.Слово «компьютер» означает «вычислитель», т.е. устройство для вычисления.

Компьютер – техническое устройство для обработки информации.

Компьютер может быть: горизонтальной компоновки, вертикальной компоновки, портативный вариант (ноутбук).

Персональный компьютер включает в себя следующие основные блоки:1. Процессор (Системный блок) – в нем располагаются основные компоненты компьютера.2. Внутренняя память (оперативная и запоминающая).3. Периферийные устройства.Процессор.

Из всех частей компьютера процессор (системный блок) выглядит наиболее скромно, но именно он является главной частью. В системном блоке располагаются все основные компоненты компьютера и именно к нему подключаются монитор, клавиатура и любые дополнительные устройства, которые могут входить в состав ПК. Центральный процессор осуществляет арифметические и логические операции, заданные программой, управляющие вычислительным процессом и координирующие работу всех устройств компьютера.Основные узлы ПК находящиеся внутри процессора:1.Системная плата (материнская плата), к которой подключаются все остальные платы и микросхемы (микропроцессор, оперативная память, контроллеры различных устройств);2.накопитель на жестком магнитном диске (винчестер);3.дисководы для чтения и записи гибких магнитных дисков, компакт-дисков и видео-дисков;4.блок питания.

Системная плата (материнская плата) – главная часть системного блока, так как на ней располагаются микросхемы и электронные платы, обеспечивающие работу компьютера обеспечивающие работу компьютера. Существуют два типоразмера материнских плат «АТ» и «АТХ».На материнской плате установлены микропроцессор и набор микросхем, специально предназначенные для работы микропроцессора.Процессор – «Мозг» компьютера. Он представляет собой небольшую (несколько сантиметров) электронную схему, выполняющую все вычисления и обработку информации.Важнейшими характеристиками процессора являются:1. разрядность – длина двоичного кода, который процессор может обрабатывать одновременно;2. тактовая частота – количество тактов процессора за 1 секунду;3. адресное пространство – максимальное количество памяти, которое процессор может обслуживать.

Контроллеры – платы с электронными схемами, управляющими различными устройствами компьютера (монитором, клавиатурой, мышью, дисководами и т.д.)

Портами – называют контакты (разъемы) находящиеся на контроллерах и выведенные на тыльную сторону системного блока.

Кулер (Cooler). Процессор при работе нагревается, поэтому корпус процессора необходимо охлаждать. Для этого используют специальные радиаторы с вентиляторами – кулеры.

Дисплей.

Монитор в ПК предназначен для вывода на экран графической или текстовой информации. Монитор по диагонали бывает 14, 15, 17, 19, 21 дюйм (1 дюйм = 2,54 см.).

Мониторы бывают:

1.ЭЛТ (на основе электронно – лучевой трубки);

2.ЖК (жидко – кристаллический монитор).

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота