В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
пптл
пптл
07.05.2022 05:05 •  Информатика

написать программу для машины Поста
1. Число k задано на ленте k метками. Увеличить число на единицу, если: 1) каретка находится где-то над массивом меток. 2) каретка находится где-то слева от массива.

2. На ленте задан массив меток. Увеличить его на два.

3. Два числа заданы на ленте двумя массивами меток. Сложить эти числа. Расстояние между массивами может быть: 1 метка; несколько меток.

Показать ответ
Ответ:
ХОРОШИСТ1234567891
ХОРОШИСТ1234567891
25.02.2023 20:04
//C# first problem
using System;
class Programm
{
  static void Main()
  {
     int n=int.Parse(Console.ReadLine());
     int[] a=new int [n];
     for (int i=0;i<n;i++)
     {
        a[i]=i;
        Console.Write(a[i] + " ");
     }
  }
}

//C# second problem
using System;
class Programm
{
  static void Main()
  {
     int n=int.Parse(Console.ReadLine());
     int[] a=new int [n];
     int ma=0,mi=0,ma_p=0,mi_p=0;
     for (int i=0;i<n;i++)
     {
        a[i]=int.Parse(Console.ReadLine);
     }
     ma=a[0];mi=a[0];ma_p=0;mi_p=0;
     for (int i=0;i<n;i++)
     {
        if (ma<a[i]){ma=a[i];ma_p=i;}
        if (mi>a[i]){mi=a[i];mi_p=i;}
     }
     ma=a[ma_p];
     a[ma_p]=a[mi_p];
     a[mi_p]=ma;
     for (int i=0;i<n;i++){Console.Write(a[i] + " ");}
  }
}
0,0(0 оценок)
Ответ:
seletkovaolya
seletkovaolya
21.05.2020 07:09
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

procedure CreateFile(p:string);
begin
  var f:=OpenWrite(p);
  Writeln(f,'В чащах юга жил бы цитрус? Да, но фальшивый экземпляръ!');
  Writeln(f,'СЪЕШЬ ЖЕ ЕЩЁ ЭТИХ МЯГКИХ ФРАНЦУЗСКИХ БУЛОК, ДА ВЫПЕЙ ЧАЮ');
  Writeln(f,'ФлегмаТичНая этА веРБлЮдиЦа жует у пОДЪезда засыХающий горький шиповник');
  Writeln(f,'The quick brown fox jumps over the lazy dog');
  Writeln(f,'THE FIVE BOXING WIZARDS JUMP QUICKLY');
  f.Close
end;

procedure UpFile(p:string);
begin
  var a:=ReadAllLines(p);
  WriteAllLines(p,a.Select(s->UpperCase(s)).ToArray);
end;

begin
  var p:=ReadlnString('Введите имя файла (можно, с путём):');
  CreateFile(p);
  UpFile(p);
  // контроль работы
  ReadAllLines(p).Println(NewLine)
end.

Пример работы
Введите имя файла (можно, с путём): MyTest.txt
В ЧАЩАХ ЮГА ЖИЛ БЫ ЦИТРУС? ДА, НО ФАЛЬШИВЫЙ ЭКЗЕМПЛЯРЪ!
СЪЕШЬ ЖЕ ЕЩЁ ЭТИХ МЯГКИХ ФРАНЦУЗСКИХ БУЛОК, ДА ВЫПЕЙ ЧАЮ
ФЛЕГМАТИЧНАЯ ЭТА ВЕРБЛЮДИЦА ЖУЕТ У ПОДЪЕЗДА ЗАСЫХАЮЩИЙ ГОРЬКИЙ ШИПОВНИК
THE QUICK BROWN FOX JUMPS OVER THE LAZY DOG
THE FIVE BOXING WIZARDS JUMP QUICKLY
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота