В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
denis1120
denis1120
05.02.2023 19:05 •  Информатика

Написать программу для отыскания max(min(a,b), min(c, не используя сложные логические условия и вложенные ветвления. числа a,b,c,d - целые. протестировать программу для следующих исходных данных: а) a=4 b=5 c=6 d=9 б) a=2 b=1 c=6 d=9 в) a=2 b=1 c=8 d=4 г) a=12 b=1 c=6 d=9

Показать ответ
Ответ:
Liza1556
Liza1556
06.07.2020 11:12
Var a,b,c,d,m1,m2,max:integer;
begin
write('Введите a,b,c,d: ');
readln(a,b,c,d);
if a<b then m1:=a else m1:=b;
if c<d then m2:=c else m2:=d;
if m1<m2 then max:=m2 else max:=m1;
writeln('MAX=',max)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота