В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
alyaardasenova
alyaardasenova
03.04.2023 09:06 •  Информатика

Написать программу для паскаль! , , ! дано натуральное число. установить, является ли последовательность его цифр, при просмотре их слева направо, по убыванию.

Показать ответ
Ответ:
Sofia1863
Sofia1863
05.10.2020 02:21
// PascalABC.NET 3.2, сборка 1370 от 24.12.2016
// Внимание! Если программа не работает, обновите версию!

begin;
  var s:=ReadInteger('n=').ToString;
  If s.Length<>(s.Distinct.Count) then Writeln('не является')
  else
    if s=s.ToCharArray.SortedDescending.JoinIntoString('')
    then Writeln('является') else Writeln('не является')
end.

Примеры
n= 9875431
является

n= 9753321
не является

n= 9763421
не является

Замечание: учтено, что упорядоченность должна быть по убыванию а не по невозрастанию. т.е. нельзя, чтобы попадались две одинаковые цифры.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота