В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ehidna666
ehidna666
04.06.2022 22:27 •  Информатика

Написать программу для паскаля: массив а, состоящий из 10 целых элементов задан через random. все элементы массива разделить на 2 элемент. вывести на экран старый и новый массив.

Показать ответ
Ответ:
SonyaKot1
SonyaKot1
18.04.2020 11:03
//Pascal ABC.NET v3.1 сборка 1172

Const
 n=10;

Var
 ar:array[1..n] of real;
 i:integer;
 k:real;
begin
randomize;
 writeln('First array:');
 for i:=1 to n do
  begin
   ar[i]:=random(100);
   write(ar[i]:4);
  end;
 k:=ar[2];
 for i:=1 to n do
  ar[i]:=ar[i]/k;
 writeln;
 writeln('Final array:');
 for i:=1 to n do
  writeln(ar[i]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота