В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
masha9form
masha9form
01.10.2021 10:09 •  Информатика

Написать программу для подсчета количества счастливых билетов выданных и оставшихся если ваш билет под № n

Показать ответ
Ответ:
function isLucky(a: integer): boolean;
var s: string;
begin  
    str(a, s);  
    while length(s) < 6 do s := '0' + s;  
    isLucky := ord(s[1]) + ord(s[2]) + ord(s[3]) = ord(s[4]) + ord(s[5]) + ord(s[6])
end;
var 
    sTicket: string;    
    iTicket, i, err, sum: longint;
begin  
    write('Введите Ваш номер билета: ');  
    read(sTicket);  
    val(sTicket, iTicket, err);  
    for i := 1 to iTicket do    
        if isLucky(i) then inc(sum);  
    writeln('Выдано ', sum, ' счастливых билетов');  
    writeln('Осталось выдать ', 55251 - sum, ' счастливых билетов')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота