В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Написать программу для решения квадратных уравнений при функций (main должна состоять только из их вызовов).

Показать ответ
Ответ:
pycya2006
pycya2006
27.05.2020 18:47

Вы не указали на каком языке Вам необходимо это решить. Поэтому выкладываю решение на C#.

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

 

namespace ConsoleApplication1

{

class Program

{

static double[] Solve(double A, double B, double C, out bool Fail)

{

Fail = false;

double D = B * B - A * C;

double[] res = new double[2];

if (D >= 0)

{

res[0] = (Math.Sqrt(D) + B) / (2 * A);

res[1] = (Math.Sqrt(D) - B) / (2 * A);

}

else

{

Fail = true;

}

return res;

}

static void Main(string[] args)

{

bool Fail = false;

Console.WriteLine("Введите коэффициент при x^2");

double A = Double.Parse(Console.ReadLine());

Console.WriteLine("Введите коэффициент при x");

double B = Double.Parse(Console.ReadLine());

Console.WriteLine("Введите свободный коэффициент");

double C = Double.Parse(Console.ReadLine());

double[] res = Solve(A, B, C, out Fail);

if (Fail)

{

Console.Write("Дискриминант меньше нуля\n");

}

else

{

for (int i = 0; i < res.Length; i++)

{

Console.Write("x{0}={1} ", i, res[i]);

}

Console.Write("\n");

}

}

}

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота