В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Dinkaakissa20
Dinkaakissa20
03.10.2020 18:30 •  Информатика

Написать программу для решения следующей : в заданной числовой последовательности найти и вывести на печать номер первого отрицательного элемента. если все элементы последовательности неотрицательны, то вывести ноль. program lab5_5; const n=10; type x=array[1..n] of integer; var a: x; i: integer; k: integer; begin for i: =1 to n do begin a[i]: =-10+random (91); write (a[i]: 4) end; writeln; k: =0; for i: =n downto 1 do if a[i]< 0 then begin k: =i end; if k> 0 then writeln (‘индекс отрицательного элемента=’,k: 1) else writeln (‘в массиве нет отрицательных элементов’); readln; end. как сделать эту программу без random чтоб работало в pascal abc?

Показать ответ
Ответ:
професорАртём
професорАртём
31.07.2020 07:30
Program lab5_5;
const n=10;
type x=array[1..n]
of integer;
var a:x;i,k:integer;
begin
for i:=1 to n do
begin
read(a[i]); {с вашего позволения я убрал "write (A[i]:4)" в остальном программа получает от пользователя 10 чисел и обрабатывает их}
end;
writeln;
k:=0;
for i:=n downto 1 do
if a[i]<0 then
begin
k:=I
end;
if k>0 then
writeln ('Индекс отрицательного элемента=',k:1)
else
writeln ('В массиве нет отрицательных элементов');
readln;
end. 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота