В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
зара120
зара120
07.04.2022 19:38 •  Информатика

Написать программу для решения следующей : вычислить сумму и количество положительных элементов последовательности.

Показать ответ
Ответ:
artiktikhonov
artiktikhonov
01.10.2020 12:22
Var
  sum, count, t : integer;
begin
  sum := 0; count := 0;
  while not eoln do
  begin
    read (t);
    if t > 0 then
    begin
      sum := sum + t;
      count := count + 1;
    end;
  writeln (sum, ' ', count);
end.

если количество элементов указано
var
  sum, count, t, n, i : integer;
begin
  sum := 0; count := 0;
  read (n);
  for i := 1 to n do 
  begin
    read (t);
    if t > 0 then
    begin
      sum := sum + t;
      count := count + 1;
    end;
  writeln (sum, ' ', count);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота