В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Boss21888
Boss21888
12.03.2020 22:12 •  Информатика

Написать программу для решения : сравнить первую и последнюю цифру натурального четырёхзначного числа n. на экране должен появиться запрос на ввод числа и результат решения , например 1) вводится число 1475, выводится «первая цифра меньше последней: 1< 5». 2) вводится число 3452, выводится «первая цифра больше последней: 3> 2». 3) вводится число 7457, выводится «первая цифра равна последней: 7=7»

Показать ответ
Ответ:
yibiuninmk
yibiuninmk
09.10.2020 13:25

var n:integer;

begin

write('Введите 4-х значное число: ');

readln(n);

if n div 1000 = n mod 10 then write('Первая цифра равна последней: ',n div 1000,'=',n mod 10)

else if n div 1000 > n mod 10 then write('Первая цифра больше последней: ',n div 1000,'>',n mod 10)

else write('Первая цифра меньше последней: ',n div 1000,'<',n mod 10)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота