В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
lianaderzkaya82
lianaderzkaya82
24.09.2022 11:57 •  Информатика

Написать программу для решения задачи:

От пользователя запрашивается трёхзначное положительное число. Необходимо поменять в числе десятки и единицы местами (например из числа 123 получится 132), затем вычислить сумму получившегося и исходного числа.

Показать ответ
Ответ:
valiullina12601
valiullina12601
05.07.2020 20:02

1. по векторам:

использовать чертежник

алг

нач

сместиться на вектор (1.75,0)

опустить перо

сместиться на вектор (0.5,0)

сместиться на вектор (0,0.5)

сместиться на вектор (1,0)

сместиться на вектор (-1, 1)

сместиться на вектор (0.75,0)

сместиться на вектор (-1,1)

сместиться на вектор (-1,-1)

сместиться на вектор (0.75,0)

сместиться на вектор (-1,-1)

сместиться на вектор (1,0)

сместиться на вектор (0,-0.5)

поднять перо

сместиться в точку (0,0)

кон

2. по точкам:

использовать чертежник

алг

нач

сместиться в точку (1.75,0)

опустить перо

сместиться в точку (2.25,0)

сместиться в точку (2.25,0.5)

сместиться в точку (3.25,0.5)

сместиться в точку (2.25, 1.5)

сместиться в точку (3,1.5)

сместиться в точку (2,2.5)

сместиться в точку (1,1.5)

сместиться в точку (1.75,1.5)

сместиться в точку (0.75,0.5)

сместиться в точку (1.75,0.5)

сместиться в точку (1.75,0)

поднять перо

сместиться в точку (0,0)

кон

0,0(0 оценок)
Ответ:
милана695
милана695
05.05.2023 21:28
Var
 X1,Y1,X2,Y2,X3,Y3:real;
 A,B,C:real;

Begin
Write('X1 = ');ReadLn(X1);
Write('Y1 = ');ReadLn(Y1);
Write('X2 = ');ReadLn(X2);
Write('Y2 = ');ReadLn(Y2);
Write('X3 = ');ReadLn(X3);
Write('Y3 = ');ReadLn(Y3);
A:=sqrt(sqr(X2-X1) + sqr(Y2-Y1) );
B:=sqrt(sqr(X2-X3) + sqr(Y2-Y3) );
C:=sqrt(sqr(X3-X1) + sqr(Y3-Y1) );
if (A<B+C)and(B<A+C)and(C<A+B) then
Begin
WriteLn('Длины сторон равны:');
WriteLn('A = ',A);
WriteLn('B = ',B);
WriteLn('C = ',C);
X1:=(A+B+C)/2;
WriteLn('Площадь треугольника равна ',sqrt(X1*(X1-A)*(X1-B)*(X1-C)))
End
else WriteLn('Треугольник не существует')
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота