Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Залму111
06.06.2022 05:52 •
Информатика
Написать программу для с++ найти такое натуральное число m, которое при развороте даст натуральное число n. sample input: 1185671 sample output: 1765811 заранее
Показать ответ
Ответ:
ЛордТарнум
08.10.2020 19:44
#include <iostream>
using namespace std;
int main()
{
int m,n,a,b;
n=0;
cin>>m;
while(m!=0)
{
d=m%10;
m=m/10;
n=d+n*10;
}
cout<<endl<<n<<endl;
system("pause");
return 0;
}
Вроде-бы работает как надо,удачи:)
0,0
(0 оценок)
Популярные вопросы: Информатика
Angelamur
18.11.2021 14:11
Что такое эргономика? Как правильно организовать свое рабочее место за компьютером? Приведите примеры действий,которые можно и нельзя совершать,работая за компьютером. Какие упражнения...
kristinka140320
30.05.2022 18:01
посмотри сколько стоит у тебя в городе арендовать электросамокат, Допустим, ты собираешься кататься на самокате ежедневно в среднем по 30 мин в день. Узнай, сколько стоит электросамокат...
Aizhan190901
16.01.2021 10:38
Для создания текстого документа используют программу...
sagatsayazhan
19.04.2020 16:57
Дано целое число n( 0). сформировать и вывести целочисленный массив размера n,содержащий n первых отрицательных нечетных чисел: -1, -3, -5, …. (программа должна иметь процедуру)...
danilnikitin624
21.12.2021 14:31
Объем файла с записью песни «urgent» группы «foreigner» составляет 2500 кбайт. время записи файла на диск составило 2 минуты 40 секунд.скорость записи составила kbps....
elyaminaewap06uze
20.07.2022 22:56
Дана последовательность операторов: a: =1 ; b: =1 ; repeat a: =a+1 ; b: =b*2 ; until b 8 ; s: =a+b сколько раз будет повторён цикл и каким будут значения переменных a b s после...
Obcenceee
19.09.2021 09:10
Решить в паскале. определить делится ли модуль разности введенных чисел 5...
roofman93p08nel
19.09.2021 09:10
Числа фибоначчи – элементы числовой последовательности 0, 1, 1, 2, 3, 5, 8, 13, 21, 34, 55, 89, 144, 233, 377, 610, 987, 1597, 2584, 4181, 6765, …, в которой каждое последующее...
Chopykoe
19.09.2021 09:10
Сколько понадобится дискет, чтобы заменить 1 тб?...
troft
19.09.2021 09:10
Дано масив а[n..1] скласти програму яка в масиві всі додатні числа збільшує на 2 а всі від ємні числа зменшує на 2 паскаль...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
using namespace std;
int main()
{
int m,n,a,b;
n=0;
cin>>m;
while(m!=0)
{
d=m%10;
m=m/10;
n=d+n*10;
}
cout<<endl<<n<<endl;
system("pause");
return 0;
}
Вроде-бы работает как надо,удачи:)