В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
karolinetynfag
karolinetynfag
15.05.2021 17:13 •  Информатика

Написать программу для суммирования четных элементов на нечетных позициях в одноименном массиве

Показать ответ
Ответ:
Ксения095
Ксения095
08.07.2020 23:04
Const
  n = 30;

var
  a: array[1..n] of integer;
  i, s: integer;

begin
  Randomize;
  Writeln('Исходный массив');
  s := 0;
  for i := 1 to n do
  begin
    a[i] := Random(101) - 50;
    Write(a[i], ' ');
    if ((i mod 2) = 1) and ((a[i] mod 2) = 0) then s := s + a[i]
  end;
  Writeln(#13#10, 'Сумма найденных элементов ', s)
end.

Тестовое решение:
Исходный массив
49 -39 -17 6 24 38 20 50 6 -36 -4 -7 -31 41 -8 20 32 49 -48 -47 50 48 -41 -44 -26 -11 9 38 -24 -34
Сумма найденных элементов 22
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота