В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
eka445590226
eka445590226
12.02.2020 18:52 •  Информатика

Написать программу для вычисления y и z значения (на языке C/C++) ja - это если
citos gadijumos - в другом случае
(Перевод с латышского языка ja, citos gadijumos)


Написать программу для вычисления y и z значения (на языке C/C++) ja - это если citos gadijumos - в

Показать ответ
Ответ:
лёванчик228
лёванчик228
29.03.2022 07:00
#include <iostream>
using namespace std;
const int N = 8; //длина массива
int s = 0; //начальное значение суммы
int mas[N]; //объявляем статический массив длины N
int main()
{
    //вводим элементы массива
    for(int i = 0; i < N; ++i)
    {
        cin >> mas[i];
    }
    //пробегаемся по элементам массива
    for(int i = 0; i < N; ++i)
    {
        if(mas[i] > 0) //если элемент массива больше 0
            s += mas[i]; //прибавляем значение элемента к итоговой сумме
    }
    cout << s; //вывод суммы на экран
    return 0;
}
0,0(0 оценок)
Ответ:
run5555
run5555
05.04.2020 18:33
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
begin
  var a:=-1.32;
  var b:=1.49;
  var h:=0.11;
  var y1:=-14.0;
  var y2:=17.0;
  var k:=0;
  var x:=a;
  while x<=b do begin
    var y:=Tan(x);
    if (y>=y1) and (y<=y2) then begin
      Writeln('x=',x:5:2,'  y=',y:7:4);
      Inc(k)
      end;
    x+=h
    end;
  Writeln('Найдено значений: ',k)
end.

Результат
x=-1.32  y=-3.9033
x=-1.21  y=-2.6503
x=-1.10  y=-1.9648
x=-0.99  y=-1.5237
x=-0.88  y=-1.2097
x=-0.77  y=-0.9697
x=-0.66  y=-0.7761
x=-0.55  y=-0.6131
x=-0.44  y=-0.4708
x=-0.33  y=-0.3425
x=-0.22  y=-0.2236
x=-0.11  y=-0.1104
x= 0.00  y= 0.0000
x= 0.11  y= 0.1104
x= 0.22  y= 0.2236
x= 0.33  y= 0.3425
x= 0.44  y= 0.4708
x= 0.55  y= 0.6131
x= 0.66  y= 0.7761
x= 0.77  y= 0.9697
x= 0.88  y= 1.2097
x= 0.99  y= 1.5237
x= 1.10  y= 1.9648
x= 1.21  y= 2.6503
x= 1.32  y= 3.9033
x= 1.43  y= 7.0555
Найдено значений: 26
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота