В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
gopas11123
gopas11123
28.12.2022 04:18 •  Информатика

Написать программу: гречу, массой х г, рассыпают по пакетам: по а г в каждый. пакетов может быть неограниченное количество. сколько гречи будет в последнем заполненном пакете? , .

Показать ответ
Ответ:
Danil200000006
Danil200000006
24.07.2020 10:56
// Написать программу: Гречу, массой х г, рассыпают по пакетам: по а г в каждый. 
//Пакетов может быть неограниченное количество. Сколько гречи будет в
//последнем заполненном пакете?

var x,a  : longword;
begin
  writeln ('Введите общую массу гречи, в граммах');
  readln (x);
  writeln ('Введите массу насыпаемой в пакет гречи, в граммах');
  readln (a);
  writeln ('полных пакетов будет ',(x div a));
  if (x mod a)=0  then writeln ('В последнем насыпанном пакете будет ',a,' грамм гречи')
                  else writeln ('В последнем насыпанном пакете будет ',(x mod a),' грамм гречи');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота