В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Мила5411
Мила5411
08.03.2020 07:16 •  Информатика

Написать программу и начертить блок-схемы решения задач:
Дан массив вещественных чисел, состоящий из 10 элементов. Найти максимальный элемент массива.

Показать ответ
Ответ:
roksanaatalan
roksanaatalan
13.10.2020 09:52

попробуй это. Тут еще с нахождением его номера

var a:array[1..100] of real;

    i,imax,n:integer;    

max:real;

begin

write('N= ');

readln(n);

for i:=1 to n do     read(a[i]);

writeln('');

imax:=0;

max:=a[1];

for i:=1 to n do     if a[i]>max then

begin max:=a[i];imax:=i;

end;

writeln('max = ',a[imax],' nomer = ',imax);

readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота