Написать программу и составить блок-схему, отладить ее, протестировать. С клавиатуры вводятся высота (в миллиметрах) и площадь (в сантиметрах) треугольника. Вычислить его стороны и периметр.
Var min,max,i,s,n:integer; begin randomize; write('Введите диапазон: '); readln(min,max); if(min>max) then begin max:=max+min; min:=max-min; max:=max-min; end; write('Введите количество чисел: '); readln(n); for i:=1 to n do begin n:= min + random(max-min); write(i,'-е число: ', n); if((n>6) and (not odd(n))) then begin s:=s+n; writeln(' (Четное и >6, сумма равна: ', s,')') end else begin write(' (Не четное'); if(n>6) then writeln(', но >6)') else writeln(' и <6)'); end; end; write('Сумма четных чисел >6 равна: ',s); end.
#include <iostream>#include <cmath>using namespace std;int main(){ int x; float A; cout<<"Введите х="; cin>>x; if (x >= M_PI){ A=0; cout<<"y=0"; } else if(M_PI>x && x>=0) { A=sin(x); cout<<"y=sin(x)"; } else if (0>x && x>=-2){ A=0; cout<<"y="; } else if (x<=-2) { A = pow((x+2),2); cout <<"y="; }
return 0;}
begin
randomize;
write('Введите диапазон: '); readln(min,max);
if(min>max) then begin
max:=max+min;
min:=max-min;
max:=max-min;
end;
write('Введите количество чисел: '); readln(n);
for i:=1 to n do begin
n:= min + random(max-min);
write(i,'-е число: ', n);
if((n>6) and (not odd(n))) then begin
s:=s+n;
writeln(' (Четное и >6, сумма равна: ', s,')')
end
else begin write(' (Не четное');
if(n>6) then writeln(', но >6)')
else writeln(' и <6)');
end;
end;
write('Сумма четных чисел >6 равна: ',s);
end.