В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
arsenteva99i
arsenteva99i
15.12.2020 11:58 •  Информатика

Написать программу, используя цикл с параметром (for), для вычисления суммы: S=1+1/2+1/3+1/4++1/n

Показать ответ
Ответ:
ArtMaster455
ArtMaster455
20.06.2021 06:29

c++

#include <iostream>

using namespace std;

int main() {

double s = 0; int n;

cin >> n;

for (int i = 1; i < n + 1; i++)

 s += 1. / i;

cout << s;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота