В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
lanedaGo
lanedaGo
19.04.2020 06:06 •  Информатика

Написать программу, используя три вида циклов (цикл с параметром, цикл с предусловием, цикл с постусловием) - 20 пункт

Показать ответ
Ответ:
Chevalier26
Chevalier26
29.07.2020 16:54
Адрес сети получается в результате поразрядной конъюнкции(умножения) IP- адреса и маски
1)  В результате умножения ip и маски первые 2 байта останутся теми же, что в ip, а последний байт станет равен 0
Что мы сейчас имеем: Адрес сети - 12.16.x.0
Найдем x:
Переведем  3 байт (196) в двоичную систему счисления: 196 = 128 + 64 + 4
Получается 196 (10) = 11000100 (2)
Переведем 224 в двоичную систему счисления: 224 = 128 + 64 +32
Получается 224 (10) = 11100000 (2)
Теперь нам нужно умножить двоичные представления чисел 196 и 224:
11000100
11100000

11000000(2)
Переведем 11000000(2) в десятичную систему счисления = 128+64 = 192
ответ: 12.16.192.0

2) В результате умножения ip и маски первые 2 байта останутся теми же, что в ip, а последний байт станет равен 0
Что мы сейчас имеем: Адрес сети - 146.212.x.0
Найдем x:
Переведем  3 байт (200) в двоичную систему счисления: 200 = 128 + 64 +8
Получается 200 (10) = 11001000 (2)
Переведем 240 в двоичную систему счисления: 240 = 128 + 64 +32 +16
Получается 240 (10) = 11110000 (2)
Теперь нам нужно умножить двоичные представления чисел 200 и 240:
11001000
11110000

11000000 (2)
Переведем 11000000(2) в десятичную систему счисления = 128+64 = 192
ответ: 146.212.192.0
0,0(0 оценок)
Ответ:
LiksiGalaxy
LiksiGalaxy
21.03.2021 00:29
Var
  i,d,dmin,dmax,kmax,imin,imax:integer;
  n:longint;
begin
  Write('Введите натуральное число N: '); Read(n);
  dmin:=10; dmax:=-1; {больше большего и меньше меньшего}
  i:=0;
  repeat
    d:=n mod 10; n:=n div 10; Inc(i);
    if dmax<d then begin dmax:=d; kmax:=1; imax:=i end
    else if dmax=d then Inc(kmax);
    if dmin>d then begin dmin:=d; imin:=i end
  until n=0;
  Writeln('Минимальная цифра - ',dmin,' находится в разряде ',imin,';');
  Writeln('Максимальная цифра - ',dmax,' находится в разряде ',imax,';');
  Writeln('Сумма максимальной и минимальной цифры - ',dmin+dmax,';');
  Writeln('Максимальная цифра встречается ',kmax,' раз(а);');
  Write('Минимальная цифра - ');
  if (dmin mod 2)=0 then Writeln('четная.')
  else Writeln('нечетная.')
end.

Тестовое решение:
Введите натуральное число N: 388456
Минимальная цифра - 3 находится в разряде 6;
Максимальная цифра - 8 находится в разряде 4;
Сумма максимальной и минимальной цифры - 11;
Максимальная цифра встречается 2 раз(а);
Минимальная цифра - нечетная.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота