В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Написать программу к задаче на языке программирования Python.
В магазине купили и ручек по 30 тенге и в карандашей по 15 тенге. Заплатили m тенге. Сколько получено сдачи s тенге?

Показать ответ
Ответ:
Аня4678
Аня4678
17.08.2021 03:44
Const CSize1=7;
      CSize2=6;
      CSize3=5;
type TMas1=array[1..CSize1,1..CSize1] of integer;
     TMas2=array[1..Csize2, 1..CSize2] of integer;
     TMas3=array[1..Csize3, 1..CSize3] of integer;

var A1:TMas1;
    A2:TMas2;
    A3:TMas3;
    i,j,x, y:byte;

function zero(i:integer):boolean;
begin
zero:=false;
if i=0 then zero:=true;
end;

function interval(i:integer):boolean;
begin
interval:=false;
if (i<=12) and (i>=1) then interval:=true;
end;

begin
X:=0;
Y:=0;
randomize;
for i:=1 to CSize1 do
 begin
 for j:=1 to CSize1 do
  begin
  A1[i, j]:=random(50);
  write(A1[i, j]:3);
  if zero(A1[i, j]) then inc(x);
  if interval(A1[i,j]) then inc(y);
  end;
 writeln;
 end;
writeln('Kol-vo 0 =', x);
writeln('Kol-vo v intervale=', y);
writeln;
x:=0;
y:=0;
for i:=1 to CSize2 do
 begin
 for j:=1 to CSize2 do
  begin
  A2[i, j]:=random(50);
  write(A2[i,j]:3);
  if zero(A1[i,j]) then inc(x);
  if interval(A2[i,j]) then inc(y);
  end;
 writeln;
 end;
writeln('Kol-vo 0 =', x);
writeln('Kol-vo v intervale=', y);
writeln;
x:=0;
y:=0;
for i:=1 to CSize3 do
 begin
 for j:=1 to CSize3 do
  begin
  A3[i, j]:=random(50);
  write(A3[i,j]:3);
  if zero(A3[i,j]) then inc(x);
  if interval(A3[i,j]) then inc(y);
  end;
 writeln;
 end;
writeln('Kol-vo 0 =', x);
writeln('Kol-vo v intervale=', y);
writeln;
x:=0;
y:=0;
end.
0,0(0 оценок)
Ответ:
yyeyheh
yyeyheh
28.05.2023 00:01
Максимальное число, составленное из утроенного произведения цифр  будет 
9*3*N  -  не  может быть больше 54,  т.е.  
N может быть только 1 или 2.  По условию х>=10  ->  N=2  (N -порядок числа).
Поэтому искать нужно среди чисел от 11 до 54.  Решение - число 15.

var n,m: integer;
begin
  write('n = ');  readln(n);
  if n=2 then
  begin    m:=11;
    repeat
      if (m mod 10)*(m div 10)*3=m then
      begin
        writeln('число:  ',m);
        m:=55;
      end;
      m:=m+1;
    until m>54;
  end
  else  writeln('нет решения');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота