В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Написать программу , как в паскале.
в массиве содержатся сведения о возрасте учеников класса.вычислить количество учащихся, чей возраст не превышает среднего.​

Показать ответ
Ответ:
ZнyцPлaй
ZнyцPлaй
14.06.2022 08:54
1. Общее количество символов 1800 + 2 х 3000 = 7800. Пусть символы кодируются в однобайтном коде ASCII, тогда 7 800 символов имеют информационный объём 7 800 байт или 7800 х 8 =62 400 бит. При скорости передачи 1200 бит/с на передачу этой информации потребуется время
62400 / 1200 = 52 с
2.  Предполагая кодировку ASCII определим объем информации:
7920 х 40 х 8 = 2 534 400 бит.
Скорость передачи составит 2534400 / 33 = 76 800 бит/с
3. Переводим килобайты в биты (1 Кбайт = 1024 байта, 1 бит = 8 байт):
3750 х 1024 х 8 = 30 720 000 бит.
Переводим минуты в секунды: 2 х 60 = 120 с
Определяем скорость передачи: 30720000 / 120 = 256 000 бит/с
1)  500 Кбайт = 500 х 1024 х 8 = 4 096 000 бит.
Время передачи данных 4096000 / 128000 = 32 с
2) За 2 минуты, равные 2 х 60 = 120с, будет передано
256000 х 120 = 30 720 000 бит.
Переводим в килобайты: 30720000 / 8 / 1024 = 3 750 Кбайт
3)  3000 Кбайт = 3000 х 1024 х 8 = 24 576 000 бит
5 минут - это 5 х 60 = 300 с
Скорость передачи данных составит 24576000 / 300 = 81 920 бит/с
0,0(0 оценок)
Ответ:
ooo29
ooo29
10.05.2022 17:53
PascalABC.Net
var
  x,y,z:integer;
  m:single;
begin
  Write('Введите x,y,z: '); Read(x,y,z);
  m:=(max(max(3*x,y*z-x),z+x)+6*z)/(-5*min(x,z));
  Writeln(m)
end.

Тестовое решение:
Введите x,y,z: 3 6 -2
-0.3

Borland Pascal 7.01
uses Crt;
function max(m,n:integer):integer;
begin if m>n then max:=m else max:=n end;
function min(m,n:integer):integer;
begin if m<n then min:=m else min:=n end;
var
  x,y,z:integer;
  m:real;
begin
  ClrScr;
  Write('Введите x,y,z: '); Read(x,y,z);
  m:=(max(max(3*x,y*z-x),z+x)+6*z)/(-5*min(x,z));
  Writeln(m);
  ReadKey
end.

Тестовое решение:
Введите x,y,z: 3 6 -2
-3.0000000000E-01
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота