В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
alhanovak2
alhanovak2
15.06.2020 04:53 •  Информатика

Написать программу "калькулятор", которая выводит результат выполнения одной из операций( + ; - ; * ; / ) над двумя числами a и b. (pascal)

Показать ответ
Ответ:
abutalip1
abutalip1
04.08.2020 12:28
Var A,B:real;
C:integer;
Begin
WriteLn(1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление, 0 - выход);
ReadLn(C);
While C <> 0 do
   Begin
   Write(Введите два числа: );
   ReadLn(A,B);
   Write(ответ: );
   Case C of
   1:WriteLn(A+B);
   2:WriteLn(A-B);
   3:WriteLn(A*B);
   4:WriteLn(A/B);
   End;
   WriteLn(1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление, 0 - выход);
   ReadLn(C);
   End;
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота