В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
maksdodaruk1
maksdodaruk1
21.03.2021 19:31 •  Информатика

Написать программу,каторая выделит все запятые из строки st начиная с позиции р

Показать ответ
Ответ:
demondru
demondru
30.09.2020 14:26

 {Программа на Free Pascal}

Var st:string;

z,p,i:integer;

begin

z:=0;

readln(st);{Считываем строку}

read(p);{Считываем позию}

for i:=p to length(st) do if(st[i] = ',') then inc(z);{Пробегаемся по строке с позиции p и ищем ,}

writeln(z);{Выводим кол-во найденых запятых}

end.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота