В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
маша3057
маша3057
10.02.2022 01:04 •  Информатика

написать программу, которая будет создавать массив из 8 чисел и заполнять целыми числами по возрастанию от 5. Т.е. массив будет выглядеть так: 5 6 7 8 9

Показать ответ
Ответ:
jakupbekova860
jakupbekova860
05.06.2022 05:39

# Задание 1

num = input('Введи целое число: ')

print('Количество цифр в числе = {}'.format(len(num)))

# Задание 2

from random import randint

print('Выпало {}'.format(randint(1, 6)))

# Задание 3

a = int(input('Введи 1 число: '))

b = int(input('Введи 2 число: '))

i = min(a, b)

while True:

   if i % a == 0 and i % b == 0:

       break

   i += 1

print(f'НОК = {i}')

# Задание 4

def fibonacci(n):

   a = 0

   b = 1

   if n < 0:

       print("Некорректный ввод!")

   elif n == 0:

       return a

   elif n == 1:

       return b

   else:

       for i in range(2, n):

           c = a + b

           a = b

           b = c

       return b

n = int(input('Введи N-ое число Фибоначчи: '))

print('Число Фибоначчи = {}'.format(fibonacci(n)))

Объяснение:

Python 3.8.2

0,0(0 оценок)
Ответ:
unikkum22
unikkum22
06.01.2021 23:27
Var a,b:longint;
function sum (n:integer):integer;
  var s:integer;
  begin
     s:=0;
     while (n<>0) do
       begin
         s:=s+n mod 10;
         n:=n div 10;
       end;
     sum:=s; 
  end;
  begin
    write ('A = ');
    readln (a);
    write ('B = ');
    readln (b);
    if sum(a) > sum(b) then
       writeln ('Сумма цифр 1ого числа больше на ',sum(a)-sum(b))
    else if sum(b) > sum (a) then 
       writeln ('Cумма цифр 2ого числа больше на ',sum(b)-sum(a))
    else writeln ('Сумма цифр 1ого числа равна сумме цифр 2ого числа');
    readln;
  end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота