В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
sabrinamaryan
sabrinamaryan
06.03.2021 19:52 •  Информатика

Написать программу, которая будет выводить четырехзначное число в обратном поряядке.

Показать ответ
Ответ:
nuramanjol
nuramanjol
13.09.2020 12:24

Объяснение:

program Xxx;

const

  RndLimit = 10000;

var

  x : integer;

begin

Repeat x := Random(RndLimit) until x > 999;

  writeLn('Random X= ', x);

  WriteLn('Modifyed X=', (x mod 1000 mod 100 mod 10), (x mod 1000 mod 100 div 10) , (x mod 1000 div 100) , (x div 1000) );

end.

Free Pascal Compiler version 2.6.2-8 [2014/01/22] for x86_64                                                                          

Copyright (c) 1993-2012 by Florian Klaempfl and others                                                                                

Target OS: Linux for x86-64                                                                                                            

Compiling main.pas                                                                                                                    

Linking a.out                                                                                                                          

10 lines compiled, 0.3 sec                                                                                                            

                                                       

Random X= 5488                                                                                                                        

Modifyed X=8845                                                                                                                        

                                                                                                                                     

                                                                                                                                     

...Program finished with exit code 0                                                                                                  

Press ENTER to exit console

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота