В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
polyakovred
polyakovred
12.11.2021 11:41 •  Информатика

Написать программу которая даст таблицу q5*5. каждый эелемент таблицы случайное число из отрезка [-30,+30]. вычислить сумму все отрицательных и сумму положительных элементов.

Показать ответ
Ответ:
лиза27011971
лиза27011971
26.05.2020 22:51

var a,b,i,j,p,o: integer;
z:real;
m:array[0..31,0..31] of integer;
begin
randomize;
for i:=1 to 5 do
for j:=1 to 5 do
begin
z:=random;
b:=random(31);
if z<0.5 then m[i,j]:=b;
if z>0.5 then m[i,j]:=-b;
end;
for i:=1 to 5 do
for j:=1 to 5 do
begin
if m[i,j]>0 then p:=p+m[i,j];
if m[i,j]<0 then o:=o+m[i,j];
end;
write(p,' ',o);
end.

 

мда. подумать над задачкой пришлось немного) но вот результат)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота