В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Olgadaleewa
Olgadaleewa
17.06.2020 18:51 •  Информатика

Написать программу, которая добавляет пробелы в строку.(то есть: если в тексте есть знак препинания «.», «,», «! » или «? », и после отсутствует пробел)

Показать ответ
Ответ:
Clever23465
Clever23465
01.10.2020 19:10
Var
  s1,s2:string;
  i,k:integer;
begin
readln(s1);
k:=length(s1)-1;
s2:='';
for i:=1 to k do
  begin
    s2:=s2+s1[i];
    case s1[i] of
      '.',',','!','?':
        if s1[i+1]<>' ' then s2:=s2+' ';
    end;
  end;
s2:=s2+s1[k+1];
writeln(s2)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота