Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
диана2473
28.09.2020 20:50 •
Информатика
Написать программу которая из двух строк составляет третью, путём чередования символов первой и второй строки.
Показать ответ
Ответ:
LipskiyTimur
12.07.2020 14:38
program tref;
var a1,a2,a3:string;i,c,b,j,a:integer;
begin
a:=1;
b:=1;
readln(a1);
readln(a2);
a3:=a1+a2;for i:=1 to length(a1)*2 do
begin
if(i mod 2 = 1)then
begin
a3[i]:=a1[b];
b:=b+1; end;;
if(i mod 2 = 0)then
begin
a3[i]:=a2[a];
a:=a+1;
end;
end;
writeln(a3);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
pikulev
27.03.2023 22:08
Плесс определите наименьшее возможное основание системы счисления n, для которого выполняется соотношение [tex]103_{n+3}[/tex] = [tex]201_{n}[/tex]+1 в качестве ответа...
мяв1
19.01.2023 03:03
Разработать программу слияния двух отсортированных по убыванию значений элементов файлов f1 и f2. результатом слияния должен быть файл f3, элементы которого по возрастанию....
gabdrahmanovaafyun
08.12.2021 01:25
Напишите двоично-четверичную таблицу соответствия....
anastasia559
15.06.2021 00:22
Как установить интервал между буквами 1 пт?...
Рената515
24.06.2020 08:53
составьте кроссворд. 12 вопросов (6 на перевод из десятичной сс и 6 в десятичную)....
sofa285
07.12.2020 23:58
Отметьте все возможные инструменты для разработки сайта: * язык программирования Сиязык программирования Паскальязык разметки гипертекста HTMLэлектронные таблицыконструктор...
RomisuRomi
29.01.2021 01:28
охарактеризуйте фреску с изображением Ноева ковчега в цвете. охарактеризуйте её, обратив внимание на композицию,образы и предметы, колорит, перспективу...
kuro4
03.07.2020 20:33
Саша написал на доске 6745 6745 6745 он хочет стереть несколько цифр так чтобы они образовали возможное число кратное девяти...
rybakovjaroslav
22.08.2020 01:53
Автомашина 54 км/сағ жылдамдықпен координаталар басынан кері бағытта қозғалып келеді. Оның бастапқы орны 20м БЖББ...
lzhaleeva
07.10.2021 18:47
Задание 2. Сгруппируйте горные породы по происхождению: Происхождение Горная порода 1 Магматические Уголь, нефть, газ, мел, песок, поваренная соль 2. Осадочные в...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var a1,a2,a3:string;i,c,b,j,a:integer;
begin
a:=1;
b:=1;
readln(a1);
readln(a2);
a3:=a1+a2;for i:=1 to length(a1)*2 do
begin
if(i mod 2 = 1)then
begin
a3[i]:=a1[b];
b:=b+1; end;;
if(i mod 2 = 0)then
begin
a3[i]:=a2[a];
a:=a+1;
end;
end;
writeln(a3);
end.