В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
carollaim
carollaim
16.03.2023 16:20 •  Информатика

Написать программу которая из двух введенных с клавиатуры чисел определяет большее и возводит его в квадрат,а меньшее делит на 8

Показать ответ
Ответ:
lina5555555
lina5555555
25.08.2020 13:51
// PascalABC.NET 3.1, сборка 1214 от 09.04.2016
begin
  var a,b:real;
  Write('Введите a и b: '); Read(a,b);
  if a>b then (a,b):=(b,a);
  Println(a/8,b*b)
end.

Тестовое решение:
Введите a и b: 34 12.7
1.5875 1156
0,0(0 оценок)
Ответ:
Y4ehik300
Y4ehik300
25.08.2020 13:51
Var
  a, b: real;

begin
  readln(a, b);
  if a = b then writeln('Числа равны')
  else
  if a > b then begin
    a := sqr(a);b := b / 8;
  end
  else begin
    b := sqr(b);a := a / 8;
  end;
  writeln('a = ', a, ' b=', b)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота