В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
KetZu
KetZu
01.10.2021 03:16 •  Информатика

Написать программу которая методом обмена пузырька сортирует по убыванию введённый с клавиатуры одномерный массив .(с++)​

Показать ответ
Ответ:
Svet1k03
Svet1k03
09.10.2020 23:10

c = int(input('Enter 2 to start'))

while c != 1:

   import math as m

   a = int(input('Write a: '))

   b = int(input('Write b: '))

   c = int(input('Write c: '))

   D = (b ** 2) - (4 * a * c)

   print ('D =',D)

   if D > 0:

       print('D > 0')

       x = (-b + (m.sqrt(D))) / (2 * a)

       x1 = (-b - (m.sqrt(D))) / (2 * a)

       print ('x1 =',x)

       print ('x2 =',x1)

   elif D == 0:

       print('D = 0')

       x = -b / (2 * a)

       print ('x =',x)

   else:

       print('D < 0')

       print ('No roots')

   c = int(input('Enter 1 to quit or 2 to repeat'))

0,0(0 оценок)
Ответ:
Кэт32131
Кэт32131
25.09.2020 17:32
Const
  n = 11;

var
  x: array[1..n] of integer;
  i, k, d, s: integer;

begin
  Randomize;
  Writeln('Элементы массива');
  k := 0; s := 0;
  for i := 1 to n do
  begin
    d := Random(11) - 5;
    Write(d:3);
    if (i mod 2) = 0 then begin { четное место }
      if d = 1 then Inc(k);
      x[i] := d
    end
    else begin
      if d < 0 then s := s + d;
      x[i] := sqr(d)
    end
  end;
  Writeln;
  Writeln('Результирующий массив');
  for i := 1 to n do Write(x[i]:3);
  Writeln;
  Writeln('Количество единиц на четных местах равно ', k);
  Writeln('Сумма отрицательных элементов на нечетных местах равна ', s)
end.

Тестовое решение:
Элементы массива
 -3  0 -5  1  5  1 -3 -4  5 -3 -2
Результирующий массив
  9  0 25  1 25  1  9 -4 25 -3  4
Количество единиц на четных местах равно 2
Сумма отрицательных элементов на нечетных местах равна -13
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота