В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ilariyao
ilariyao
09.11.2021 23:33 •  Информатика

Написать программу , которая находит и выводит на печать все четырёхзначные числа abcd , для которых выполняется : a , b ,c ,d - разные цифры ab-cd=a+b+c+d

Показать ответ
Ответ:
tatleb
tatleb
21.06.2020 08:15
{Задачу можно решать несколькими Одним из возможных является перебор всех четырехзначных чисел и проверка для каждого из них выполнения условий. Попробуем сократить перебор, для этого преобразуем второе условие:
10а+b-(10c+d)=a+b+c+d;
9(a-c)=2(c+d);
(a-c)/(c+d)=2/9
Проанализировав первое условие, получаем, что а=с+2, d=9-c, следовательно 0<=c<=7.}

program prim4;
  uses crt;
  var a,b,c,d: integer;
begin
  clrscr;
  for c:=0 to 7 do 
    begin
      a:=c+2; d;=9-c;
      for b:=0 to 9 do 
        begin
          if (b<>c)and(b<>a)and(b<>d)
          then
          write(a,b,c,d);
          writeln
        end;
    end;
  readln;
end.

{Таким образом, мы решили задачу, значительно сократив перебор.}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота