В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Daniil2305
Daniil2305
11.01.2021 01:30 •  Информатика

Написать программу, которая находит минимальное из трех введенных чисел. Числа являются целыми.

Входные данные: х1,х2,х3 (целые числа).

Выходные данные: минимальное из этих чисел.

Ниже представлен вариант выполнения программы.

Введите 3 целых числа

15 30 8

Минимальное из этих чисел 8

Ниже представлен другой вариант выполнения программы.

Введите 3 целых числа

5 18 50

Минимальное из этих чисел 5 ​

Показать ответ
Ответ:
CatMyBoss
CatMyBoss
10.03.2023 13:39

Составим полный код к нашему заданию а:

program ex1;

uses crt;

var

 k, a: integer;

begin

 k := 1;a := 12;

 while a < 100 do

 begin

   a := 2 * a - 4;

   Writeln('Значения a ', a);

   k := k + 1;

   Writeln('Значения k ', k);

 end;

end.

После выполнения программы получаем такие значения:

Значения a 20

Значения k 2

Значения a 36

Значения k 3

Значения a 68

Значения k 4

Значения a 132

Значения k 5

Составим полную программу к заданию б:

program ex2;

uses crt;

var

 k, a, s: integer;

begin

 s := 0;a := 1;k := 1;

 while a < 50 do

 begin

   s := s + a;

   Writeln('Значения s ', s);

   k := k + 1;

   Writeln('Значения k ', k);

   a := k * k;

   Writeln('Значения a ', a);

 end;

end.

После выполнения программы получаем такие значения:

Значения s 1

Значения k 2

Значения a 4

Значения s 5

Значения k 3

Значения a 9

Значения s 14

Значения k 4

Значения a 16

Значения s 30

Значения k 5

Значения a 25

Значения s 55

Значения k 6

Значения a 36

Значения s 91

Значения k 7

Значения a 49

Значения s 140

Значения k 8

Значения a 64

0,0(0 оценок)
Ответ:
9Kira9
9Kira9
10.03.2023 13:39

Составим полный код к нашему заданию а:

program ex1;

uses crt;

var

 k, a: integer;

begin

 k := 1;a := 12;

 while a < 100 do

 begin

   a := 2 * a - 4;

   Writeln('Значения a ', a);

   k := k + 1;

   Writeln('Значения k ', k);

 end;

end.

После выполнения программы получаем такие значения:

Значения a 20

Значения k 2

Значения a 36

Значения k 3

Значения a 68

Значения k 4

Значения a 132

Значения k 5

Составим полную программу к заданию б:

program ex2;

uses crt;

var

 k, a, s: integer;

begin

 s := 0;a := 1;k := 1;

 while a < 50 do

 begin

   s := s + a;

   Writeln('Значения s ', s);

   k := k + 1;

   Writeln('Значения k ', k);

   a := k * k;

   Writeln('Значения a ', a);

 end;

end.

После выполнения программы получаем такие значения:

Значения s 1

Значения k 2

Значения a 4

Значения s 5

Значения k 3

Значения a 9

Значения s 14

Значения k 4

Значения a 16

Значения s 30

Значения k 5

Значения a 25

Значения s 55

Значения k 6

Значения a 36

Значения s 91

Значения k 7

Значения a 49

Значения s 140

Значения k 8

Значения a 64

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота