В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ekaterinaf79
ekaterinaf79
11.01.2023 09:26 •  Информатика

Написать программу, которая находит сумму элементов последовательности из 5 целых чисел. получить новую последовательность путем замены всех ненулевых элементов исходной последовательности на разность между элементом последовательности и найденной суммой.

Показать ответ
Ответ:
IrishkaKoteika2689
IrishkaKoteika2689
14.07.2020 13:25
Program Project1;
var   
a:array[1..5] of Integer;   
i, j, sum:Integer;   
s:string;
begin 
Readln(s); 
sum:=0; 
 for i:=1 to 5 do 
    begin   
         if (Length(s)>=2) then   
            begin     
              j:=Pos(' ', s);     
             a[i]:=StrToInt(Copy(s, 1, j-1));     
             sum:=sum+a[i];     
             Delete(s, 1, j);   
             end   
         else   
     begin     
      a[i]:=StrToInt(s);     
      sum:=sum+a[i];   
    end; 
end; 
   for i:=1 to 5 do 
      begin   
         if (a[i]<>0) then   
              begin     
                a[i]:=a[i]-sum;     
                Write(a[i], ' ');   
              end   
         else   
           begin     
              a[i]:=a[i];     
              Write(a[i], ' ');   
           end; 
      end; 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота