В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
muzycuk
muzycuk
27.03.2023 13:07 •  Информатика

Написать программу,которая находит все четырехзначные числа abcd,для которых выполняются условия 1)a,b,c,d-разные цифры 2)a*b-c*d=a+b+c+d

Показать ответ
Ответ:
vanaromanihinp077sx
vanaromanihinp077sx
03.07.2020 22:34
Program fofgogjoj;
var 
a,b,c,d:integer;
begin
for c:=0 to 7 do 
begin
a:=c+2; 
d:=9-c;
for b:=0 to 9 do 
begin
if (b<>c)and(b<>a)and(b<>d) then
Writeln(a,b,c,d);
Writeln;
end;
end;
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота