В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
dVioletta
dVioletta
17.06.2022 19:07 •  Информатика

Написать программу, которая находит все двузначные числа и их количество, которые делятся на n или содержат цифру n

Показать ответ
Ответ:
Undina705
Undina705
26.05.2020 12:55

#include <iostream>
using std::cout;
using std::cin;
using std::endl;

int main()
{
    int n, counter = 0;

    cout << "Enter N: ";
    cin >> n;

    for(int i = 10; i < 100; i++)
    {
        if(i % n == 0 || i % 10 == n || i / 10 == n)
        {
            counter++;

            cout << i << ' ';
        }
    }

    cout << '\n' << counter << " numbers" << endl;

   return 0;
}


Написать программу, которая находит все двузначные числа и их количество, которые делятся на n или с
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота