Написать программу, которая определит все четырёхзначные числа являющиеся симметричными, т.е abcd a+b=c+d и вывести на экран через пробелы, посчитав при этом их количество
Program n; uses crt; var i,a,b,c,d,k:integer; begin k:=0; for i:=1000 to 9999 do begin a:=i div 1000; b:=i div 100 mod 10; c:=i div 10 mod 10; d:=i mod 10; if a+b=c+d then begin write(i,' '); k:=k+1; end; end; writeln; writeln(k,' шт''); end.
uses crt;
var i,a,b,c,d,k:integer;
begin
k:=0;
for i:=1000 to 9999 do begin
a:=i div 1000;
b:=i div 100 mod 10;
c:=i div 10 mod 10;
d:=i mod 10;
if a+b=c+d then begin
write(i,' '); k:=k+1; end;
end; writeln;
writeln(k,' шт'');
end.