В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
rlynx675
rlynx675
30.08.2022 19:09 •  Информатика

Написать программу, которая определяет какой элемент максимальный или минимальный первым встречается в одномерном массиве из 10 чисел(паскаль)

Показать ответ
Ответ:
Svetlana2675
Svetlana2675
02.07.2020 01:24
Consr n=10;
var a,i,max,min,k,p:integer;
m:array [1..n] of integer;
begin
for i:=1 to n do
begin
a:=random(21)-10;
m[i]:=a;
write (m[i],' ');
end;
max:=m[1];
min:=m[1];
k:=1;
p:=1;
for i:=1 to n do
begin
if m[i]>max then
  begin
  max:=m[i];
  p:=i;
  end;
if m[i]<min then
  begin
  min:=m[i];
  k:=i;
  end;
end;
if p>k then writeln ('минимальный раньше')
else writeln ('максимальный раньше');
end.
0,0(0 оценок)
Ответ:
HanNazbi
HanNazbi
02.07.2020 01:24
Во вложении
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота