В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
lilia822
lilia822
10.08.2020 20:39 •  Информатика

Написать программу, которая определяет сколько единиц в числе, которое ввёл пользователь. например, в числе 197313 – две единицы. ( циклом)

Показать ответ
Ответ:
aaysu228
aaysu228
11.10.2020 03:05

program p1;

var n,k1:integer;

begin

k1:=0;

write ('Введите число ');

readln (n);

write ('Количество единиц в числе ',n,' равно ');

repeat

if n mod 10 = 1 then k1:=k1+1;

n:=n div 10;

until n=0;

write(k1);

end.

0,0(0 оценок)
Ответ:
igor331
igor331
11.10.2020 03:05

На python:

Объяснение:

a = input("Введите число: ")

b = 0

for i in list(a):

   if i == '1':

       b += 1

print("'1' - ", b)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота