В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Shamorinka
Shamorinka
13.06.2021 02:43 •  Информатика

Написать программу, которая осуществляет вывод одномерного массива, поиск максимального значения и выводит его индекс в этом массиве.

Показать ответ
Ответ:
NastyaAnaNastya
NastyaAnaNastya
20.07.2020 09:52
Var i,imax,amax:integer;
a:array[1..10] of integer;
begin
writeln('Введите числа');
for i:=1 to 10 do
begin
write('a[',i,']= ');
read(a[i]);
end;
a[1]:=amax;
imax:=1;
for i:=1 to 10 do
if amax<a[i] then
begin
amax:=a[i];
imax:=i;
end;
writeln('Исходный массив');
for i:=1 to 10 do
write(a[i]:4);
writeln;
writeln('Элемент под номером ',imax,' имеет максимальное значение равное ',amax);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота