В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
bullet699
bullet699
17.01.2021 00:55 •  Информатика

Написать программу, которая печатает true или false в зависимости от того, выполняются или нет заданные условия: - квадрат заданного трехзначного числа равен кубу суммы цифр этого числа; -точка с координатами (x,y)принадлежит части плоскости,лежащей между прямыми x=m,x=n(m

Показать ответ
Ответ:
OrAcUl
OrAcUl
24.05.2020 22:46

var b: 100..999;

      s: word;

      x, y, m, n: integer;

begin

  writeln('Введите трехзначное число');

  readln(b);

  s:=(b mod 10)+((b mod 100)div 10)+(b div 100); //сумма цифр трехзначного числа

  if sqr(b)=sqr(s)*s then writeln('True')

  else writeln('False');

  writeln('Введите координаты х и у');

  readln(x, y);

  writeln('Введите m и n');

  readln(m, n);

  if (x>m)and(x<n) then writeln('True')

  else writeln('False');

end.

  

     

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота