В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
stetcenko87
stetcenko87
30.10.2021 18:35 •  Информатика

Написать программу, которая перемещает все нули в конец списка. Ваша задача — изменить список так, что бы нули оказались в конце списка.
Порядок ненулевых чисел должен сохранится.
Пример:
[0, 1, 0, 3, 12] -> [1, 3, 12, 0, 0]
[0] -> [0]
[1, 0, 3, 0, 0, 0, 5] -> [1, 3, 5, 0, 0, 0, 0]
[9, 0, 7, 31, 0, 45, 0, 45, 0, 45, 0, 0, 96, 0] -> [9, 7, 31, 45, 45, 45, 96, 0, 0, 0, 0, 0, 0, 0]

Показать ответ
Ответ:
тоня119
тоня119
19.07.2022 06:00

i = []

for a in input().split():

   i.append(int(a))

i.sort(key=lambda x: x==0)

print(i)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота