В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
prunsesca005
prunsesca005
27.12.2020 08:03 •  Информатика

Написать программу, которая переводит из двоичной в десятичную систему счисления на с# или с.

Показать ответ
Ответ:
ангелина123456543216
ангелина123456543216
07.10.2020 08:07
Using System;

public class Test
{
public static void Main()
{
int n=0, d=1;
Console.WriteLine("Введите двоичное число: ");
string s = Console.ReadLine();
for (int i=0; i<s.Length; i++){
   if (s[i]=='1') n += d;
   d *= 2;
}
Console.WriteLine("n = {0}", n);
Console.ReadKey();
}
}

Пример:
Введите двоичное число: 1110111
n = 119
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота