В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
kokocuk01
kokocuk01
30.09.2021 20:18 •  Информатика

Написать программу которая подсчитает количество нечётных отрицательных чисел до заданного отрицательного числа а(-200

Показать ответ
Ответ:
Nika5647
Nika5647
05.11.2020 13:41
1. 256 цветов - 2⁸, следовательно для хранения информации о цвете 1 пикселя необходимо 8 бит = 1 байт. В одном килобайте - 1024 байт.
640*480/1024 = 300 Кбайт

2. Для начала найдем количество бит на пиксель:
4*1024*8/128/128 = 2, двумя битами можно закодировать черно-белый рисунок, цветов - 2

3. Простая арифметика. Все перемножаем, умножаем на количество страниц и переводим из битов в мегабайты:
800*600*24*4/8/1024/1024≈5.4 Мбайт

4. Для хранения информации о 65535 цветах пикселя надо 16 бит, а для 256 - 8 бит. ответ: 16/8 =2 раза

5. 16 = 2⁴, значит для 1 пикселя требуется 4 бита. Для всей картинки получим:
800*600*4=1920000 бит = 1920000 байт=1875 Кбайт
0,0(0 оценок)
Ответ:
Неуч00
Неуч00
22.07.2020 04:37

//Обьявляем дополнительные переменные и главный массив, а также два дополнительных - они будут "половинками".

var

 a, b, c: array [1..100] of longint;

 i, min, n, j, t: longint;

begin

 //Читаем количество элементов в нашем массиве.

 readln(n);

 

 //Читаем массив.

 for i := 1 to n do read(a[i]);

 

 //Заполняем первую "половинку".

 for i := 1 to n div 2 do b[i] := a[i];

 

 //Заполняем вторую "половинку". Но раз это уже вторая "половинка" главного массива, то и

 //цикл теперь должен начинаться со второй части массива, а заканчиваться уже в его конце.

 for i := n div 2 + 1 to n do c[i - n div 2] := a[i];

 

 //Теперь отсортируем первую "половинку" методом выбора. Идея этого метода

 //основывается на том, что мы ищем минимальный среди неотсортированных элемент,

 //а затем аем его с тем, который стоит сразу после отсортированных.

 for i := 1 to (n - 1) div 2 do

 begin

   min := i;

   for j := i + 1 to n div 2 do

     if b[min] > b[j] then

       min := j;

   if min <> i then begin

     t := b[i];

     b[i] := b[min];

     b[min] := t;

   end;

 end;

 

 //Затем вторую точно также, только стоит обратить внимание на сравнения.

 //Так как надо отсортировать по убыванию, то теперь сравнение перед "swap"-ом

 //будет другим.

 for i := 1 to (n - 1) div 2 do

 begin

   min := i;

   for j := i + 1 to n div 2 do

     if c[min] < c[j] then

       min := j;

   if min <> i then begin

     t := c[i];

     c[i] := c[min];

     c[min] := t;

   end;

 end;

 

 //А теперь по очереди выводим готовые "половинки", не забывая ставить

 //пробел после вывода каждого элемента.

 for i := 1 to n div 2 do write(b[i], ' ');

 for i := 1 to n - n div 2 do write(c[i], ' ');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота