В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
bbezza66
bbezza66
20.09.2021 11:30 •  Информатика

написать программу , которая подсчитывает сумму натуральных чисел от 1 до n (с циклом for, while, repeat

Показать ответ
Ответ:
kthjxrfqqq
kthjxrfqqq
24.08.2020 01:52

ЦИКЛ FOR:

var s,i,n: integer;

begin

write('Введите n: ');

readln(n);

s:=0;

for i:=1 to n do

s:=s+i;

writeln('Сумма равна ',s);

end.

ЦИКЛ WHILE:

var s,i,n: integer;

begin

write('Введите n: ');

readln(n);

s:=0;

i:=1;

while (i<=n) do

begin

s:=s+i;

i:=i+1;

end;

writeln('Сумма равна ',s);

end.

ЦИКЛ REPEAT:

var s,i,n: integer;

begin

write('Введите n: ');

readln(n);

s:=0;

i:=1;

repeat

s:=s+i;

i:=i+1;

until i>n;

writeln('Сумма равна ',s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота