Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
tanysha4957
07.02.2020 21:53 •
Информатика
Написать программу, которая показывает пользователю список животных и предлагает выбрать одно из них. после того, как пользователь сделал выбор, программа в ответ показывает какие звуки издает выбранное животное. на с++
Показать ответ
Ответ:
Stoianova1988
07.10.2020 11:18
/*VS C++*/
#include <iostream>
using namespace std;
int main() {
setlocale(LC_ALL, "Russian");
cout << "Выберите животное:" << endl;
cout << "1 - Собака" << endl;
cout << "2 - Петух" << endl;
cout << "3 - Кот" << endl;
int a;
cin >> a;
switch (a) {
case 1: {
cout << "Гав-гав." << endl;
break;
}
case 2: {
cout << "Кукареку." << endl;
break;
}
case 3: {
cout << "Мяу." << endl;
break;
}
default: cout << "Животное с таким номером отсутствует!" << endl;
}
system("pause");
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
eltsina01
12.06.2022 17:46
Сор выполняя панорамную съемку, оператор использовал штатив, но получил размытое изображение. опишите две причины, по которой это могло произойти....
ivangladkikh
18.09.2020 22:45
Где взялись слова писать азбука диктант карандаш каникулы...
evrolokki
18.09.2020 22:45
Составить программу нахождения площади прямоугольника,если известны его стороны...
Eva5768
24.04.2022 03:29
с программированием, надо сделать в питоне...
ЧерепашкаВася
27.05.2021 20:31
Вследующих словах и предложениях найдите ошибки и исправьте их, запишите исправленный вариант. 1.чрезмерное употребление алкоголя вредит здоровью. 2. были предприняты все мероприятия...
artem2006voskanyan
03.04.2020 11:16
Ускільки разів період коливань маятника на місяці відрізняється від періоду коливань того ж маятника на землі (прискорення вільного падіння на місяці в 6 разів менше, ніж на...
kristinaбатурина2054
18.02.2020 22:46
Гнаться синонимы? антонимы? дремать синонимы ? антонимы? прильнуть синонимы ? антонимы?...
kotrboy
31.12.2022 11:06
Чому атом сульфуру має змінну валентність?...
vladukhtin2280
18.02.2020 22:46
Ссочинение на 10 класс по тексту (м.кронгауз) начинается так хх век оказался интересным не только для не получается буду только раставте с1 с2 с3 с4...
umeson
24.03.2023 21:06
Определить токи переходного процесса в ветвях схемы после замыкания выключателя sa, если эдс источника e=220в, r1=2000ом, r2=1500 ом, c=150 мкф...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <iostream>
using namespace std;
int main() {
setlocale(LC_ALL, "Russian");
cout << "Выберите животное:" << endl;
cout << "1 - Собака" << endl;
cout << "2 - Петух" << endl;
cout << "3 - Кот" << endl;
int a;
cin >> a;
switch (a) {
case 1: {
cout << "Гав-гав." << endl;
break;
}
case 2: {
cout << "Кукареку." << endl;
break;
}
case 3: {
cout << "Мяу." << endl;
break;
}
default: cout << "Животное с таким номером отсутствует!" << endl;
}
system("pause");
return 0;
}