Написать программу, которая позволяет пользователю ввести 4 целых числа, проверяя, что все числа разные. И: 1) Проверяет, делится ли первое число на второе, третье и четвертое одновременно, а также делить ли хоть на какое-то из трех.
2) Находит значения выражений (a-b)/(c-d) и a/(c+b+d), проверяя возможность вычисления.
3) Находит наибольшее и наименьшее среди четырех чисел.
Все это - код ОДНОЙ программы, сдаёте вы тоже один файл.
У меня получилось 6, но если ответ другой должен получиться, то надеюсь разберешься там с прогой и исправишь
Объяснение:
var x,y,n,b,c,q:integer;
f:array [-1..1000] of integer;
begin
for var i:=1 to 1000 do begin
if i<=15 then
f[i]:=2*i*i+4*i+3;
if (i>15) then
if (i mod 3=0) then
f[i]:= f[n-1]+i*i+3
else
F[i]:= f[i-2]+i-6;
end;
for var i:=1 to 1000 do begin
x:=f[i];
while x>0 do begin
b:=x mod 10;
x:=x div 10;
if b mod 2=0 then begin
q+=1; break;
end;
end;
if q=0 then
c+=1;
end;
writeln (F);
writeln (c);
end.
1.WordPad имеет гораздо больше возможностей, чем Notepad, так как это текстовый процессор, а не текстовый редактор. Он имеет интерфейс, похожий на Microsoft Word, с лентой вверху. ... В отличие от Блокнота, WordPad предлагает несколько типов экспорта. По умолчанию используется RTF (Rich Text Format).
Объяснение:
2.В процессе дефрагментации происходит сбор и перенос на близкое расстояние друг от друга разбросанных по жесткому диску кусочков файлов. Помимо этого, все данные перемещаются в начало жесткого диска, а свободное место располагается в его конце, что так же ускоряет доступ к данным.
3.26375
4.Чтобы найти их, вам нужно открыть меню пуск > все программы и в самом низу списка найти пункт «стандартные». На разных ОС (операционных системах) он выглядит по-разному.Paint,WordPad,Блокнот,выполнить,записки,звукозапись,команданы строка и т.д.